关于迁移服务器出现的一些问题

作者:FAWEI 发布时间: 2026-05-22 阅读量:53

1. CDN缓存规则

我没有将 Cache Key的规则关闭。这个规则在平时使用的时候是没有什么问题的,但是如果在迁移服务器的时候不把这个规则关掉,可能会出一些bug。

关于迁移服务器出现的一些问题 配图1

并且我没有把CDN规则里面的节点缓存和浏览器缓存更改为不缓存,并且还要主动清除站点的所有缓存

还有注意的一点是网站的错误代码是默认不缓存的。但是有一个例外,在EdgeOne的技术文档里面有写到, 404错误代码会默认缓存十秒钟。所以说在规则里面你也要额外将错误代码404设定为不缓存,否则会默认缓存十秒。

在操作的时候。明明已经设置成对的的,但是因为太着急。打开网站刷新了一下发现是404,我又改回错误的设置了

2.反向代理

没有正确设置反向代理中的的HTTP和HTTPS。要检查开放的端口与反向代理的端口以及地址是否一致

并且要注意自己的WAF设置,有可能拦截了CDN节点的请求。将CDN的所有节点添加至白名单。检查证书是否对应得上。我折腾了很久,一直显示525异常,查了一下是SSL握手失败。也联系了CDN的技术工程师。但是最后具体原因也是没有找到。

3.nginx配置问题

这也是我在整个迁移过程中最大的问题。

在整个迁移的过程中,我首先是在旧服务器的nginx中将网站切换成了维护模式。然后把服务器中的nginx配置文件直接复制到了新服务器的nginx配置文件中。导致了把旧服务器中的维护模式设置也带到了新服务器中

关于迁移服务器出现的一些问题 配图2

但是新服务器中维护模式的开关状态并没有更新。这就导致了一个假象:维护模式开关是关着的,但是实际上配置文件中维护模式是开着的。

(我怀疑这是个BUG)

所以说,其实我在一开始就迁移完毕了,设置什么的都是正确的。只是网站一直显示处于维护模式,导致我以为CDN依然指向旧服务器。